Plumbing nonfunctional

This is a bug i hve run into several times

Notice in the first picture it says emptying. and the pipes bugging out which I will get back to later
In the second picture it is waiting on meth despite being connected.

Yes they are connected, in at least 3 separate paths i double checked. Yes there is power to equipment. I’ve run into this problem several times, and it basicly ends the round for me. once i run into it once no new things i add to the network work. I was able to fix it once by setting down random pipes on the network. and that is why I think its related to the pipe bug.

You can see the aforementioned pipe bug where the pipes are not connecting to eachother. despite being adjacent. THis also starts happening somewhere during the setup, and is likewise usually fxed by placing down random pipes.

also shoutout to Ruko Famicon who said " I disagree, and if I wasn’t drowning in tickets I’d offer to help you understand it." who apparently knows something i don’t

Well i have pictures but i literally can’t upload them to forum, or provide a link to a imgur or something

You should report this on github.

plumbing is fuckin wierd man, but i think i understand it enough to help
first things first


for the second problem
if you enter ingreedients on a reaction chamber after wrenching it in, it tries to suck up everything youve entered so far and doesnt wait till you close the UI before filling itself, therefore the sequence goes like so

-connect plumbing constructer to network with Carbon, Hydrogen, and Oxygen
-set it to suck up Carbon in the UI
-It sucks up carbon, registers as full, and switches to the emptying state. But because it has nowhere to empty to, it can’t, and stays stuck in the emptying state
-you set it to suck up hydrogen and oxygen, but it can’t, because it’s in the emptying state, not the filling state, and has nowhere to empty TO so it can’t go back to the filling state
-you get confused and post on forums

the simple solution to this is to,wait until you set up the full reaction before wrenching down the reaction chamber, and/or using a “Plunger” on the reaction chamber after setting it up to reset it to the filling state

edits made for clarity

This isn’t the issue. I always enter the reagents, and then wrench them down afterwords for this very reason. That is it working as intended. The bug I am describing is not

alright i dont fuckin know then i tried

Maybe make a video with obs studio showing you making the setup and it not working?

Its not a thing with the setup but sure next time i play Chemist i will boot up OBS and this bug will inevitably happen again

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.